Total : 0.00 €

Before contacting us, please make sure to check our F.A.Q

Please, login or register to our website in order to be able to post a presale question in the forum.

× WooPrice Calculator PRO

[SOLVED] Encoding of output fields

More
1 year 3 months ago #946 by david
david replied the topic: Encoding of output fields
Hi Egor,
Happy Ending!
Bye David
AT14, closed
The topic has been locked.
More
1 year 3 months ago #942 by EGOR NIKISHIN
EGOR NIKISHIN replied the topic: Encoding of output fields
Hello David!
The issue suddenly dissapeared when i duplicate my stage site to prod. I've done this migration once again - from prod site to test, and issue magically fixed on my stage site too.
Now i consider it as s strange bug. I hope it won't happen again.
Thank you.
The topic has been locked.
More
1 year 3 months ago #937 by david
david replied the topic: Encoding of output fields
Hi Egor,
We found few changes in your application not done by us.
I suggest you to download the beta version (vers. 2.1.2) at altoswebsolutions.com/beta/2.1.2/woo-price-calculator.zip

you could find Instructions how to install it at altoswebsolutions.com/documentation/4-install-bugfix .
If you experience any problem, let me know
Thank you
David
The topic has been locked.
More
1 year 3 months ago #936 by david
david replied the topic: Encoding of output fields
Hi Egor,
We found few changes in your application not done by us.
I suggest you to download the beta version (vers. 2.1.2) at altoswebsolutions.com/beta/2.1.2/woo-price-calculator.zip

you could find Instructions how to install it at altoswebsolutions.com/documentation/4-install-bugfix .
If you experience any problem, let me know
Thank you
David
The topic has been locked.
More
1 year 3 months ago - 1 year 3 months ago #921 by EGOR NIKISHIN
EGOR NIKISHIN replied the topic: Encoding of output fields
Hello David!

With this update my decoding problems have been solved, but now my cart looks like this:




If i add to cart product without calc attached everything looks fine
Attachments:
Last Edit: 1 year 3 months ago by EGOR NIKISHIN.
The topic has been locked.
More
1 year 3 months ago #915 by david
david replied the topic: Encoding of output fields
Hi Egor,

We've received your credentials. To solve your problem you must download this bugfix: altoswebsolutions.com/beta/2.1.2/woo-price-calculator.zip

You can read how to install a bugfix here: altoswebsolutions.com/documentation/4-install-bugfix

Bye,
David
AT14
The topic has been locked.
More
1 year 3 months ago #914 by EGOR NIKISHIN
EGOR NIKISHIN replied the topic: Encoding of output fields
Hello!
Have you received my email with credentials?
The topic has been locked.
More
1 year 3 months ago #911 by EGOR NIKISHIN
EGOR NIKISHIN replied the topic: Encoding of output fields
Hello David and thank you for reply!

I've sent credentials to hello@

I've found that my price settings in woocommerce make difference. I use space after price. In this case i have an error. If i change price settings in woocommerce not to use space after price it works fine.

Another issue - decoding of calc labels in admin view doesn't work:
Attachments:
The topic has been locked.
More
1 year 3 months ago #910 by david
david replied the topic: Encoding of output fields
Hi Egor,
Without any link we can't see the problem.
Please write to our support mail box ( altoswebsolutions.com/contact-us ) and will will check how we can solve your problem, if you like.

Remember that the plug-in uses TF8 character encoding standard.
Bye David
The topic has been locked.
More
1 year 3 months ago #909 by EGOR NIKISHIN
EGOR NIKISHIN replied the topic: Encoding of output fields
Hello!
After update to latest version my calcs totally hangs. On product page i don't see the price, and see infinitie spin of loading sign. On my chrome dev tab i see error in decodeUtf8 function. it seems that it doesnt work well:
Uncaught URIError: URI malformed
    at decodeURIComponent (<anonymous>)
    at Object.decodeUtf8 (main.js?ver=4.9.1:375)
    at Object.success (main.js?ver=4.9.1:269)
    at i (jquery.js?ver=1.12.4:2)
    at Object.fireWith [as resolveWith] (jquery.js?ver=1.12.4:2)
    at y (jquery.js?ver=1.12.4:4)
    at XMLHttpRequest.c (jquery.js?ver=1.12.4:4)

Also i see strange symbol after price:


Please help.
Attachments:
The topic has been locked.
More
1 year 4 months ago #894 by EGOR NIKISHIN
EGOR NIKISHIN replied the topic: Encoding of output fields
Hello David and thank you for staying connected.

About markup - it's not a problem for me , i've made markup myself to fit my needs.
About sorting of output fields - it would be very helpful.
Thank you.
The topic has been locked.
More
1 year 4 months ago #892 by david
david replied the topic: Encoding of output fields
Hi Egor
We agree on your point of view about “markup is a matter of taste” so we are shifting the delivery date to match your request.

On your second issue “sorting of output fields” we are thinking about.
David
The topic has been locked.
More
1 year 4 months ago #841 by EGOR NIKISHIN
EGOR NIKISHIN replied the topic: Encoding of output fields
Hello Ataur and thank you for your help.
I think the markup is a matter of taste, and the table markup maybe isn't the best option, but it is worth adding classes to output label and value fields.

I have a different issue with sorting of output fields - it will be very helpful if you add this option. Without sorting output fields are very unpredictable and chaotic.
Thank you!
The topic has been locked.
  • Ataur Rahman
  • Ataur Rahman's Avatar
1 year 4 months ago #838 by Ataur Rahman
Ataur Rahman replied the topic: Encoding of output fields
Hello Egor,
I guess that the new version will include your request and will be released around Saturday.

Thanks
Ataur
The topic has been locked.
More
1 year 4 months ago #830 by EGOR NIKISHIN
EGOR NIKISHIN replied the topic: Encoding of output fields
Hello Ataur.

Yes, i mean this piece of code:

$outputFields   = "br>";
              /**/
                        $outputFields                   .= "<b>[/color]{$field->label}</b>: {$value}<br/>";
                    }

it generetes simple markup inside .aws_output field like <b>Test</b>:400;
i suffer from lack of markup to beautify it with css.

i've made some additional markup for me like:

$outputFields   = "<tr>";
              	
         /**/
                        $outputFields                   .= "<td class='en-woopricecalc-output-label'>{$field->label}</td>:<td class='en-woopricecalc-output-value'> {$value}</td></tr>";

but i understand that my code will be overwritten with your next update.
Could i put my overwritten file calculatorhelper.php somewhere in my child theme, in style of child plugin, or something similar?
As far as a know, wordpress doesn't support making child plugins.
The topic has been locked.
  • Ataur Rahman
  • Ataur Rahman's Avatar
1 year 4 months ago #828 by Ataur Rahman
Ataur Rahman replied the topic: Encoding of output fields
Hello Egor,
Yes, this bugfix will be included in the next release.

What do you mean markup? Hear is example "<div class="aws_output" id="aws_price_calc_ouput_ID">LABEL: VALUE</div> that you need?
The topic has been locked.
More
1 year 4 months ago #825 by EGOR NIKISHIN
EGOR NIKISHIN replied the topic: Encoding of output fields
Hello Ataur.
Yes, it works now, thank you.
Will this fix be included in next public release?
And how about a markup for output fields instead of just <br> tags?
I can make it by miself if you tell me the right place in theme where i can place the overwritten file.
The topic has been locked.
  • Ataur Rahman
  • Ataur Rahman's Avatar
1 year 4 months ago #819 by Ataur Rahman
Ataur Rahman replied the topic: Encoding of output fields
Hello Egor,
You wear right to use "decodeUtf8" to the output fields to solve the problem. We fixed directly on your website.
Thanks
Ataur
The topic has been locked.
More
1 year 4 months ago #806 by EGOR NIKISHIN
EGOR NIKISHIN replied the topic: Encoding of output fields
Hello Ataur and thank you for the answer.

i've sent email with credentials on altoswebsolutions.com/contact-us .
i suppose that problem is that the result.OutputFieds don't go throught decodeUtf8 function in main.js file.
And it would be great if output fields contained some additional markup rather than just some <br> tags.
The topic has been locked.
  • Ataur Rahman
  • Ataur Rahman's Avatar
1 year 4 months ago #801 by Ataur Rahman
Ataur Rahman replied the topic: Encoding of output fields
Hello Egor,
Could you please send us FTP and also WP-admin access credentials to altoswebsolutions.com/contact-us to solve the problem?

Thanks
Ataur
The topic has been locked.
Moderators: david
Time to create page: 0.256 seconds

Cart

Total : 0.00 €