Total : 0.00 €

Before contacting us, please make sure to check our F.A.Q

Please, login or register to our website in order to be able to post a presale question in the forum.

× WooPrice Calculator PRO

[SOLVED] At themes i have only Autogenerated thame

  • Simone
  • Simone's Avatar
1 year 9 months ago #78 by Simone
Simone replied the topic: [SOLVED] At themes i have only Autogenerated thame
Probably something didn't work with last update.
With FTP you should see a folder "themes" also in /wp-content/uploads/woo-price-calculator/. It will be empty, I guess.
Move all files you find (themes) from /wp-content/plugins/woo-price-calculator/themes/
to /wp-content/uploads/woo-price-calculator/themes.
This should solve your issue.

Regards,
S

Please Log in or Create an account to join the conversation.

More
1 year 9 months ago #77 by Eliran levi
Eliran levi replied the topic: [SOLVED] At themes i have only Autogenerated thame
So whay i can't see all themes?

Attached picture
Attachments:

Please Log in or Create an account to join the conversation.

  • Simone
  • Simone's Avatar
1 year 9 months ago #76 by Simone
Simone replied the topic: [SOLVED] At themes i have only Autogenerated thame
Actually seems to be all fine with themes. Depending on your CSS library you can choose your favourite autogenerated theme.
If you want to customize a theme you have to create a new php file with code like in example above and following our documentation.
Maybe you could also solve the issue by adding some CSS to your current product page.
You can write me the page url so I can check if is possible to solve your issue just adding some CSS. ;)

Regards,
S

Please Log in or Create an account to join the conversation.

More
1 year 9 months ago #75 by Eliran levi
Eliran levi replied the topic: [SOLVED] At themes i have only Autogenerated thame
I not try to create custom theme

at the folder i have 4 files i attached picture file with the folder
Attachments:

Please Log in or Create an account to join the conversation.

  • Simone
  • Simone's Avatar
1 year 9 months ago #74 by Simone
Simone replied the topic: [SOLVED] At themes i have only Autogenerated thame
Did yo try to create your custom theme?
Which files you see in this folder? /wp-content/plugins/woo-price-calculator/themes/

Regards,
S

Please Log in or Create an account to join the conversation.

More
1 year 9 months ago #73 by Eliran levi
Eliran levi replied the topic: [SOLVED] At themes i have only Autogenerated thame
I update to v1.2.9 and i see only one theme autogenerated

Please Log in or Create an account to join the conversation.

  • Simone
  • Simone's Avatar
1 year 9 months ago #72 by Simone
Simone replied the topic: [SOLVED] At themes i have only Autogenerated thame
Hi Eliran,

you should see 4 themes instead of 1. This is strange, which version are you using? If is not updated, please update to v.1.2.9.
Anyway you can find in our documentation how to write your custom theme so you will be able to choose where to put label and input field for each field.
woopricecalculator.com/documentation#customize-theme
I paste also the code to creare 3 fields, with this you can create your theme.
<?php
/*
 * THEME_NAME: Example Simone
 */
?>

<div class="wpc-product-form">
	<!--Field start-->
	<div id="<?php echo $this->view['data']['woo_price_calc_1']['elementId']; ?>" class="form-group wpc-field-widget">
		<div class="wpc-field <?php echo $this->view['data']['woo_price_calc_1']['class']; ?>">
		<?php echo $this->view['fields']['woo_price_calc_1']['html']; ?>
		<label for="<?php echo $this->view['data']['woo_price_calc_1']['elementId']; ?>_field">
			<?php echo $this->view['fields']['woo_price_calc_1']['label_name']; ?>
		</label>
		</div>
		<div class="wpc-field-error"></div>
	</div>
	<!--Field end-->
	<!--Field start-->
	<div id="<?php echo $this->view['data']['woo_price_calc_2']['elementId']; ?>" class="form-group wpc-field-widget">
		<div class="wpc-field <?php echo $this->view['data']['woo_price_calc_2']['class']; ?>">
		<?php echo $this->view['fields']['woo_price_calc_2']['html']; ?>
		<label for="<?php echo $this->view['data']['woo_price_calc_2']['elementId']; ?>_field">
			<?php echo $this->view['fields']['woo_price_calc_2']['label_name']; ?>
		</label>
		</div>
		<div class="wpc-field-error"></div>
	</div>
	<!--Field end-->
	<!--Field start-->
	<div id="<?php echo $this->view['data']['woo_price_calc_3']['elementId']; ?>" class="form-group wpc-field-widget">
		<div class="wpc-field <?php echo $this->view['data']['woo_price_calc_3']['class']; ?>">
		<?php echo $this->view['fields']['woo_price_calc_3']['html']; ?>
		<label for="<?php echo $this->view['data']['woo_price_calc_3']['elementId']; ?>_field">
			<?php echo $this->view['fields']['woo_price_calc_3']['label_name']; ?>
		</label>
		</div>
		<div class="wpc-field-error"></div>
	</div>
	<!--Field end-->
</div>

Regards,
Simone

Please Log in or Create an account to join the conversation.

More
1 year 9 months ago #71 by Eliran levi
Eliran levi created the topic: [SOLVED] At themes i have only Autogenerated thame
At themes i have only Autogenerated thame

at pro its need to be more thames?

The problem is that the description of the feild is long and it's at couple of rows i want it will be up to the feild

I attached a picture

Thank you
Attachments:

Please Log in or Create an account to join the conversation.

Moderators: Simonedavid
Time to create page: 0.176 seconds

Cart

Total : 0.00 €